Version Compatibilities

1
Last updated 18 days ago

Realm Object Server 3.x is backwards compatible with all SDK's that supports ROS 3.0 or later. So when a new ROS version is available, always update the server first and then the client SDKs.

While ROS supports older SDK's than the ones listed below, the versions listed are required to support the new ROS 3.0 features like Query-based Synchronization and Fine-grained Permissions.

With ROS 3.11 a new capability to compress server side files was introduced which requires updated SDK version as listed below.

ROS

Realm JS

Realm Swift + Objective-C

Realm Java

Realm .Net

Realm MSSQL

Data Adapter

Realm Postgres

Data Adapter

Realm Studio

3.0 - 3.10

>= 2.3

>= 3.2

>= 5.0

>= 3.0

>= 1.1

>= 1.1

>= 1.0

3.11 -

>= 2.17

>= 3.10

>= 5.7.0

TBD

2.0.0

1.6.0

>= 3.0

Node.js 6.0 or later is required for installation of the server.

Not what you were looking for? Leave Feedback